View Supports |
Checks whether this view supports the given worksharing display mode.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- mode WorksharingDisplayMode
- The mode of interest.
Return Value
BooleanReturns True if this view is a graphical view in a workshared document or if the desired mode is Off. Returns False if this view is a non-graphical view (such as a schedule or the project browser) or if this view is not in a workshared document.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

For convenience, the "Off" mode is always supported. Other display modes are supported by graphical views in workshared documents.