Initial |
This class is the base class for calculating initial light color.

System Object
Autodesk.Revit.DB.Lighting InitialColor
Autodesk.Revit.DB.Lighting CustomInitialColor
Autodesk.Revit.DB.Lighting PresetInitialColor
Autodesk.Revit.DB.Lighting InitialColor
Autodesk.Revit.DB.Lighting CustomInitialColor
Autodesk.Revit.DB.Lighting PresetInitialColor
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The InitialColor type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | TemperatureValue | The light color temperature value in Kelvins. |

Name | Description | |
---|---|---|
![]() | Clone | Creates a copy of the InitialColor derived object. |
![]() | Dispose | Releases all resources used by the InitialColor |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |