Initial |
This class is the base class for calculating initial light color.

System Object
Autodesk.Revit.DB.Lighting InitialColor
Autodesk.Revit.DB.Lighting CustomInitialColor
Autodesk.Revit.DB.Lighting PresetInitialColor
Autodesk.Revit.DB.Lighting InitialColor
Autodesk.Revit.DB.Lighting CustomInitialColor
Autodesk.Revit.DB.Lighting PresetInitialColor
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The InitialColor type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | TemperatureValue | The light color temperature value in Kelvins. |

Name | Description | |
---|---|---|
![]() | Clone | Creates a copy of the InitialColor derived object. |
![]() | Dispose | Releases all resources used by the InitialColor |