Rebar Set |
Sets the presentation mode for this rebar set when displayed in the given view.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- dBView View
- The view.
- presentationMode RebarPresentationMode
- The presentation mode.

Exception | Condition |
---|---|
ArgumentException | This rebar cannot have a presentation mode applied for dBView, as the view is not valid for rebar presentation, or the orientation of the view matches the normal direction of the rebar element. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
InapplicableDataException | This rebar element represents a single bar (the layout rule is Single). |