GetEntity Method


Element Get Entity Method

Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Entity GetEntity(
	Schema schema
)

Parameters

schema Schema
The Schema describing the Entity.

Return Value

Entity
The returned Entity.
Exceptions
Exception Condition
ArgumentException Reading of Entities of this Schema is not allowed to the current add-in.
ArgumentNullException A non-optional argument was null
Remarks
The Entity that is returned is a copy of the stored data (with copy-on-write optimization). Modifying it is allowed (even with restricted write), but to save your changes you must call SetEntity.
See Also