GetLabelForDiscipline Method


Label Utils Get Label For Discipline Method

Gets the user-visible name for a discipline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static string GetLabelForDiscipline(
	ForgeTypeId disciplineTypeId
)

Parameters

disciplineTypeId ForgeTypeId
Identifier of the discipline.

Return Value

String
Returns the user-visible name for a discipline.
Exceptions
Exception Condition
ArgumentException Discipline must have a definition.
ArgumentNullException A non-optional argument was null
Remarks
The name is obtained in the current Revit language.
See Also