Spatial |
SpatialElementBoundarySubface represents the geometry boundary information of spatial element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The SpatialElementBoundarySubface type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | SpatialBoundaryElement | Element that gave rise to this room face. |
![]() | SubfaceArisesFromElementFace | Indicates if the subface is coincident with a portion of a (possibly offset) face of the element. |
![]() | SubfaceType | Type of the subface. |
![]() | Valid | Indicates if the subface instance is valid and can be used. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the SpatialElementBoundarySubface |
![]() | GetBoundingElementFace | Returns the face of the bounding element. |
![]() | GetSpatialElementFace | Returns the face of the spatial element's 3D geometry. |
![]() | GetSubface | Returns a face that represents the portion of the room face bounded by the boundary element. |