CanFilterByGlobalParameters Method


Schedule Definition Can Filter By Global Parameters Method

Checks whether a field can be used with a global parameter-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool CanFilterByGlobalParameters(
	ScheduleFieldId fieldId
)

Parameters

fieldId ScheduleFieldId
The ID of the field to check.

Return Value

Boolean
True if the field can be used with a global parameter-based filter, false otherwise.
Exceptions
Exception Condition
ArgumentException fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException A non-optional argument was null
Remarks

The global parameter-based filter types are IsAsociatedWith, IsNotAssociatedWith.

Only parameters which have a compatible type with at least one existing global parameter can be filtered.

See Also