GetClosestPoint Method


Alignment Get Closest Point Method

Calculates the point on the alignment's geometry which is closest to the given model point.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ GetClosestPoint(
	XYZ point
)

Parameters

point XYZ
The model point for which to calculate the closest point.

Return Value

XYZ
The alignment point closest to the given model point.
See Also