CreateSweptGeometry Method (CurveLoop, Int32, Double, IList(CurveLoop))


Geometry Creation Utilities Create Swept Geometry(Curve Loop, Int 32, Double, IList Curve Loop ) Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Solid CreateSweptGeometry(
	CurveLoop sweepPath,
	int pathAttachmentCrvIdx,
	double pathAttachmentParam,
	IList<CurveLoop> profileLoops
)

Parameters

sweepPath CurveLoop
pathAttachmentCrvIdx Int32
pathAttachmentParam Double
profileLoops IList CurveLoop

Return Value

Solid
See Also