BuiltInFailures.BendFailures Class


Built In Failures Bend Failures Class

Failures about Bends.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures BendFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class BendFailures

The BuiltInFailures BendFailures type exposes the following members.

Properties
Name Description
Public property Static member BendAngleIsUnacceptable The angle of the bend/elbow is unacceptable
Public property Static member DeleteMiddleBendNotAllowed Delete a middle bend in a bank is not allowed
Public property Static member DeleteSegmentInBankNotAllowed Delete a segment in a bank is not allowed
Public property Static member NotBentControl While making curved beam type "[Type Name]" some Control elements were not created
Public property Static member NotBentDetailComponent While making curved beam type "[Type Name]" 2D Detail Component elements were not created
Public property Static member NotBentFilledRegion While making curved beam type "[Type Name]" Filled Region elements were not created
Public property Static member NotBentImage While making curved beam type "[Type Name]" Image elements were not created
Public property Static member NotBentImport While making curved beam type "[Type Name]" CAD File elements were not created
Public property Static member NotBentMaskingRegion While making curved beam type "[Type Name]" Masking Region elements were not created
Public property Static member NotBentModelLine While making curved beam type "[Type Name]" some Model Line elements were not created
Public property Static member NotBentOpening While making curved beam type "[Type Name]" Opening elements were not created
Public property Static member NotBentRefLine While making curved beam type "[Type Name]" some Reference Line elements were not created
Public property Static member NotBentRefPlane While making curved beam type "[Type Name]" some Reference Plane elements were not created
Public property Static member NotBentSharedFamily While making curved beam type "[Type Name]" Shared Family Instances were not created
Public property Static member NotBentSymbol While making curved beam type "[Type Name]" Symbol elements were not created
Public property Static member NotBentSymbolicLine While making curved beam type "[Type Name]" some Symbolic Line elements were not created
Top
See Also