CreateHeaderInstance Method


IFCFile Create Header Instance Method

Creates an IFC header instance in the file model.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IFCAnyHandle CreateHeaderInstance(
	string name
)

Parameters

name String
The instance name.

Return Value

IFCAnyHandle
The instance handle.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
file_schema, file_description and file_name must be created to get IFC file written successfully. Otherwise, the output IFC file would be empty.
See Also