GetDefaultNameForSchedule Method (Document, ElementId, ElementId)


View Schedule Get Default Name For Schedule(Document, Element Id, Element Id) Method

Gets the default view name that will be used when creating a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static string GetDefaultNameForSchedule(
	Document document,
	ElementId categoryId,
	ElementId areaSchemeId
)

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.
areaSchemeId ElementId
The ID of an area scheme in an area schedule, InvalidElementId otherwise.

Return Value

String
The default view name.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- In a non-area schedule, areaSchemeId is not InvalidElementId. -or- In an area schedule, areaSchemeId is not the ID of an area scheme.
ArgumentNullException A non-optional argument was null
See Also