SaveModifiedLinksOptions Enumeration


Save Modified Links Options Enumeration

Class giving options when saving linked files which have been modified in-memory by shared coordinates operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum SaveModifiedLinksOptions
Members
Member name Value Description
DisableSharedPositioning 2 Any modified linked files will not be saved. Additionally, stop using shared positioning with any modified files.
DoNotSaveLinks 1 Any modified linked files will not be saved. The links will return to their previous position the next time the file is loaded.
SaveLinks 0 Any modified linked files will be saved.
See Also