SetPointCloudScanOverrideSettings Method (ElementId, PointCloudOverrideSettings, String, Document)


Point Cloud Overrides Set Point Cloud Scan Override Settings(Element Id, Point Cloud Override Settings, String, Document) Method

Assigns scan override settings to a particular scan within a PointCloudInstance element.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetPointCloudScanOverrideSettings(
	ElementId elementId,
	PointCloudOverrideSettings newSettings,
	string scanTag,
	Document doc
)

Parameters

elementId ElementId
Id of the element to be overridden.
newSettings PointCloudOverrideSettings
Override settings to be assigned.
scanTag String
The tag identifying the particular scan within the PointCloudInstance element. Tags can be obtained from PointCloudInstance via method getScans.
doc Document
Document containing the element to be overridden.
Exceptions
Exception Condition
ArgumentException Thrown when supplied scanTag is not empty while doc is NULL
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The override settings are not valid.
See Also