AddSegment Method


Curtain Grid Line Add Segment Method

Add a segment based on the specified segment curve of the gridline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddSegment(
	Curve curve
)

Parameters

curve Curve
The curve used to locate the segment to be removed. This function will invoke regeneration.
Exceptions
Exception Condition
InvalidOperationException Segment may not have been found in location indicated by curve.
See Also