GetAllCapsStatus Method (TextRange)


Formatted Text Get All Caps Status(Text Range) Method

Returns whether All , None or a Mixed set of characters in a given text range are in all caps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FormatStatus GetAllCapsStatus(
	TextRange textRange
)

Parameters

textRange TextRange
The given text range.

Return Value

FormatStatus
The format status of all caps on characters FormatStatus .
Exceptions
Exception Condition
ArgumentException This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException A non-optional argument was null
Remarks
This function only returns All or None if the text contains one character. The given text range should not be empty.
See Also