DisconnectFromServer Method


Rebar Free Form Accessor Disconnect From Server Method

Sets the GUID of the API server to invalid value and removes all the server related data from the Rebar (ex. the current constraints and the handle tags are removed). Calling this method will result in a Rebar that will not react to host changes anymore, however it will still have all the properties that it used to have.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void DisconnectFromServer()
Exceptions
Exception Condition
InvalidOperationException This RebarFreeFormAccessor doesn't contain a valid rebar reference.
See Also