GetPointCloudRegionOverrideSettings Method (ElementId, String, Document)


Point Cloud Overrides Get Point Cloud Region Override Settings(Element Id, String, Document) Method

Gets override settings assigned to a particular region within a PointCloudInstance element.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public PointCloudOverrideSettings GetPointCloudRegionOverrideSettings(
	ElementId elementId,
	string regionTag,
	Document doc
)

Parameters

elementId ElementId
Id of the overridden element.
regionTag String
The tag identifying the particular region within the PointCloudInstance element. Tags can be obtained from PointCloudInstance via method getRegions.
doc Document
Document containing the overridden element.

Return Value

PointCloudOverrideSettings
The override settings assigned to the region, if present, or a default override settings if nothing was found.
Exceptions
Exception Condition
ArgumentException Thrown when supplied regionTag is not empty while doc is NULL
ArgumentNullException A non-optional argument was null
See Also