SetLightOn Method


Light Group Manager Set Light On Method

Turns the given light on or off for rendering the given view depending on the bool argument

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetLightOn(
	ElementId viewId,
	ElementId lightId,
	bool turnOn
)

Parameters

viewId ElementId
The Id of the view
lightId ElementId
The Id of the light to turn on or off
turnOn Boolean
Turns the light on if true, off if false
Exceptions
Exception Condition
ArgumentException The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light instance
ArgumentNullException A non-optional argument was null
See Also