Element Get |
Returns the ids of the element(s) that generated the input geometry object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Parameters
- geometryObject GeometryObject
- The geometry object whose generating element is requested.
Return Value
ICollection ElementIdThe id(s) of the element(s) that generated (or may have generated) the given geometry object. Empty if no generating elements are found. If the set contains just one id, it is the id of the element that generated the geometry object.

Exception | Condition |
---|---|
ArgumentException | The input geometryObject is invalid and so cannot be used to obtain the generating element ids. |
ArgumentNullException | A non-optional argument was null |

This function supports many different types of relationships among elements. Most of these relationships will return a single element, for example:
- Window and door cutting walls
- Openings cutting hosts
- Face splitting faces
- Wall sweep or reveal traversing wall
- Walls joining to other wall(s)
- Elements extending to roof(s)