LeaderShape Enumeration


Leader Shape Enumeration

Supported geometric shapes of annotation leaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum LeaderShape
Members
Member name Value Description
Arc 2 An arc between between the end point and anchor point. In this shape the elbow point controls the arc's radius.
Kinked 1 A kinked line with a shoulder defined by an elbow point.
Straight 0 A single straight line between the end point and anchor point.
Remarks
Although the Leader class supports all available shapes, not all types of leaders may have the option to change its shape. For example, leaders of text annotations can be of any shape, while leaders of level lines are never curved.
See Also