Connector Class


Connector Class

A connector in an Autodesk Revit MEP project document.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Connector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Connector : IConnector, IDisposable

The Connector type exposes the following members.

Properties
Name Description
Public property AllowsSlopeAdjustments Indicates if the connector allows the slope adjustment.
Public property AllRefs All references of the connector.
Public property Angle The angle of the Connector.
Public property AssignedDuctFlowConfiguration The assigned duct flow configuration of the connector.
Public property AssignedDuctLossMethod The duct loss method of the connector.
Public property AssignedFixtureUnits The assigned fixture units of the connector.
Public property AssignedFlow The assigned flow of the connector.
Public property AssignedFlowDirection The assigned flow direction of the connector.
Public property AssignedFlowFactor The assigned flow factor of this connector.
Public property AssignedKCoefficient The assigned kCoefficient of the connector.
Public property AssignedLossCoefficient The assigned loss coefficient of the connector.
Public property AssignedPipeFlowConfiguration The pipe flow configuration type of the connector.
Public property AssignedPipeLossMethod The pipe loss method of the connector.
Public property AssignedPressureDrop The assigned pressure drop of the connector.
Public property Coefficient The coefficient of the connector.
Public property ConnectorManager The connector manager of the connector.
Public property ConnectorType The connector type of the connector.
Public property CoordinateSystem The coordinate system of the connector.
Public property Demand The demand of the connector.
Public property Description The description.
Public property Direction The direction of the connector.
Public property Domain The domain of the connector.
Public property DuctSystemType The duct system type of the connector.
Public property ElectricalSystemType The electrical system type of the connector.
Public property EngagementLength Connector engagement length. When applicable, it represents the inset distance to the end of the fabrication part from the connection point. Otherwise it returns zero.
Public property Flow The flow of the connector.
Public property GasketLength Connector gasket length. When applicable, it represents the distance from the end of the fabrication part to the center of the gasket. Otherwise it returns zero.
Public property Height The height of the connector.
Public property Id A unique identifier to identify this connector.
Public property IsConnected Identifies if the connector is physically connected to a connector on another element.
Public property IsMovable whether the connector can be moved.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MEPSystem The system of the connector belong to.
Public property Origin The location of the connector.
Public property Owner The host of the connector.
Public property PipeSystemType The pipe system type of the connector.
Public property PressureDrop The pressure drop of the connector.
Public property Radius The radius of the connector.
Public property Shape The shape of the connector.
Public property Utility Indicates if the connector is a utility connector.
Public property VelocityPressure The velocity pressure of the connector.
Public property Width The width of the connector.
Top
Methods
Name Description
Public method ConnectTo Make connection between two connectors.
Public method DisconnectFrom Remove connection between two connectors.
Public method Dispose Releases all resources used by the Connector
Public method GetFabricationConnectorInfo Gets fabrication connectivity information.
Public method GetMEPConnectorInfo Gets MEP connector information.
Public method IsConnectedTo Identifies if the connector is connected to the specified connector.
Top
Remarks
This connector is an item that is a part of another element (duct, pipe, fitting, or equipment etc.). This connector does not represent the connector element that can be created inside a family; for that element, refer to ConnectorElement .
See Also