ClassificationEntry Class


Classification Entry Class

Represents an entry in the classification table.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB KeyBasedTreeEntry
Autodesk.Revit.DB ClassificationEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ClassificationEntry : KeyBasedTreeEntry

The ClassificationEntry type exposes the following members.

Constructors
Name Description
Public method ClassificationEntry Constructs a ClassificationEntry object
Top
Properties
Name Description
Public property CategoryId The id of the category associated with this entry.
Public property Description The description associated with this entry.
Public property Level The entry level in the classification table. The expected range is between 1 and 5 inclusive.
Top
Methods
Name Description
Public method HasBadCategoryId Checks if the category id is Revit BuiltInCategory id.
Public method HasBadLevel Checks if the level is an integer in range between 1 and 5 inclusive.
Public method HasInvalidKey Checks if the key matches the level and parent key.
Top
See Also