TessellatedBuildIssue Class


Tessellated Build Issue Class

Types of issues encountered while constructing geometrical objects from the tessellated face sets.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TessellatedBuildIssue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TessellatedBuildIssue : IDisposable

The TessellatedBuildIssue type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property NumberEncountered How many times this issue was encountered in its face set during the face set processing. This number can be less than the total number of such issues in the face set, as the face set processing could be aborted due to the presence of the issues which could not be handled.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the TessellatedBuildIssue
Public method GetIssueDescription Gets a string describing the issue. If the issue does not present a problem, then an empty string is returned.
Public method IsValidIssue Reports whether the issue is well-formed, valid and does describe a real problem.
Public method MakesDataUnusable Reports whether this issue makes some data unusable ('true') or is only shows that data format conventions were broken, but the data are still usable (false).
Public method ReportIssueToDataSource Reports whether this issue should be reported to the company which wrote the software which produced the face set data (true), or to Autodesk (false).
Top
See Also