AdvancedTransparent Class


Advanced Transparent Class

A static class that provides access to the property names that appear in the AdvancedTransparent visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual AdvancedTransparent

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class AdvancedTransparent

The AdvancedTransparent type exposes the following members.

Properties
Name Description
Public property Static member SurfaceAlbedo The property labeled "Color" from the "AdvancedTransparent" schema.
Public property Static member SurfaceAnisotropy The property labeled "Anisotropy" from the "AdvancedTransparent" schema.
Public property Static member SurfaceCutout The property labeled "Image" from the "AdvancedTransparent" schema.
Public property Static member SurfaceNdfType The property labeled "NDF" from the "AdvancedTransparent" schema.
Public property Static member SurfaceNormal The property labeled "Image" from the "AdvancedTransparent" schema.
Public property Static member SurfaceRotation The property labeled "Rotation" from the "AdvancedTransparent" schema.
Public property Static member SurfaceRoughness The property labeled "Roughness" from the "AdvancedTransparent" schema.
Public property Static member TransparentColor The property labeled "Color" from the "AdvancedTransparent" schema.
Public property Static member TransparentDistance The property labeled "Transparent Distance" from the "AdvancedTransparent" schema.
Public property Static member TransparentIor The property labeled "IOR" from the "AdvancedTransparent" schema.
Top
See Also