BuiltInFailures.InfillFailures Class


Built In Failures Infill Failures Class

Failures about Infill.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures InfillFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class InfillFailures

The BuiltInFailures InfillFailures type exposes the following members.

Properties
Name Description
Public property Static member CannotDeleteInfill Can't delete infilling element without deleting its insert or host.
Public property Static member FamilyInstanceIsNotCuttingHost Instance is not cutting host.
Public property Static member InfillCannotChangeType Infilling element replaced by a later phase insert must be the same type as the insert's host.
Public property Static member InfillCannotHaveDiffThickness This infilling element must have the same thickness as its host.
Public property Static member InfillDifferentPhase Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.
Public property Static member InfillLost Standalone infilling Wall is separated from its insert.
Public property Static member InfillNoSlopeGlazing Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.
Public property Static member InfillNoThicknessCeiling Could not change type due to highlighted infilling element. 'Basic Ceiling' infills are only compatible with 'Basic Ceiling' hosts.
Public property Static member InfillNoThicknessMultiface Highlighted infilling element could not have thickness different from its host because it spans multiple faces.
Public property Static member InPlaceFamilyNotCuttingHost Instance of in-place family is not cutting host.
Public property Static member InsertJoinedWall Insert conflicts with joined Wall.
Public property Static member InsertOverlapsOrOut Highlighted inserts overlap with other inserts or completely miss their hosts.
Public property Static member MovedInfillToHost Infilling element was automatically moved to keep it aligned to host.
Top
See Also