BuiltInFailures.ScheduleViewFailures Class


Built In Failures Schedule View Failures Class

Failures about Schedule.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures ScheduleViewFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ScheduleViewFailures

The BuiltInFailures ScheduleViewFailures type exposes the following members.

Properties
Name Description
Public property Static member BadViewType Schedules can only be placed on Sheets.
Public property Static member CannotResizeColumn Can't resize column.
Public property Static member ColumnsExceedSegment Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.
Public property Static member ColumnsExcluded Some columns in the project are excluded from the graphical column schedule view.
Public property Static member CustomFieldNecessaryIdDeleted An element that is needed to compute the field [field name] from [schedule name] schedule was deleted.
Public property Static member DuplicateFieldRemovedFromKeySchedule Duplicate fields across key schedules will be removed after paste.
Public property Static member NoColumnsJoinedToGridLines No columns are joined to grid lines, or view parameters exclude all columns.
Public property Static member NotGridName '[Text]' is not a Grid line name
Public property Static member PanelScheduleDataPanelSlotInconsistency The template applied to this panel schedule is set to display fewer space than what is needed to display the max amount of circuits set on the equipment.
Public property Static member PanelScheduleLoadClassInconsistency You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.
Public property Static member PanelScheduleSlotInconsistency The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.
Public property Static member PanelScheduleSwitchboardSlotInconsistency The template applied to this panel schedule is set to display fewer space than what is needed to display the max number of circuits set on the equipment.
Public property Static member SchedulesCanBePlacedOnSheetsOnly Schedules can only be placed on Sheets.
Public property Static member SegmentsStartIsGreaterThanSegmentsEnd Change values so Segments End is greater than or equal to Segments Start.
Top
See Also