KeynoteEntries Class


Keynote Entries Class

A collection of KeynoteEntry objects that make up the keynote table.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class KeynoteEntries : KeyBasedTreeEntries

The KeynoteEntries type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from KeyBasedTreeEntries )
Top
Methods
Name Description
Public method Dispose
(Inherited from KeyBasedTreeEntries )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method FindEntry Finds the KeyBasedTreeEntry associated with the given key value.
(Inherited from KeyBasedTreeEntries )
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
(Inherited from KeyBasedTreeEntries )
Public method GetEnumerator Returns an enumerator that iterates through a collection.
(Inherited from KeyBasedTreeEntries )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetKeyBasedTreeEntriesIterator Returns a KeyBasedTreeEntriesIterator that iterates through the collection.
(Inherited from KeyBasedTreeEntries )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Static member LoadKeynoteEntriesFromFile Loads the contents of a keynote text file into the provided KeyBasedTreeEntriesLoadContent.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also