GetSegmentParameterIdsAndLengths Method


Fabric Sheet Get Segment Parameter Ids And Lengths Method

Returns the array of pairs [parameter ID, length] that correspond to segments of a bent fabric sheet (like A, B, C, D etc.).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public IDictionary<ElementId, double> GetSegmentParameterIdsAndLengths(
	bool rounded
)

Parameters

rounded Boolean
Set to true to return rounded values for segments lengths.

Return Value

IDictionary ElementId , Double
Array of pairs [parameter ID, length] that correspond to segments of a bent fabric sheet (like A, B, C, D etc.) is returned for bend fabric sheet. For flat fabric sheet (not bent) empty array is returned.
Remarks
This method does not provide alphabetical nor any other order of returned parameters.
See Also