Transaction |
Assimilates all inner transactions by merging them into a single undo item.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Return Value
TransactionStatusIf finished successfully, this method returns TransactionStatus.Committed.

Exception | Condition |
---|---|
InvalidOperationException | The Transaction group has not been started (its status is not 'Started').. -or- The transaction's document is currently in failure mode. Transaction groups cannot be closed until failure handling is finished. You may use a transaction finalizer to close a group after the failure handling ends. |

After a successful assimilation the transaction group is committed.
All transactions committed inside this group will be merged into one single transaction. The resulting undo item will bear this group's name.
Assimilate can be called only when all inner transaction groups and transactions are finished, i.e. after they were either committed or rolled back.