SpacingRuleLayout Enumeration


Spacing Rule Layout Enumeration

Rules for laying out a series of equidistant points or parallel lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum SpacingRuleLayout
Members
Member name Value Description
FixedDistance 1 Points or lines are separated by a fixed distance.
FixedNumber 2 Fixed number of points or lines with uniform distance between them.
MaximumSpacing 3 Points or lines are separated by at most the max distance.
MinimumSpacing 5 Points or lines are separated by at least the minimum distance.
None 0 No points or lines will be created.
See Also