WherePasses Method


Filtered Workset Collector Where Passes Method

Applies a workset filter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FilteredWorksetCollector WherePasses(
	WorksetFilter filter
)

Parameters

filter WorksetFilter
The workset filter.

Return Value

FilteredWorksetCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The filter will be added as an additional condition that all filtered worksets must pass. If you have an active iterator to this collector it will be stopped by this call.
See Also