EnergyAnalysisDetailModelOptions Class


Energy Analysis Detail Model Options Class

Options that govern the calculations for the generation of the energy analysis detail model.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis EnergyAnalysisDetailModelOptions

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class EnergyAnalysisDetailModelOptions : IDisposable

The EnergyAnalysisDetailModelOptions type exposes the following members.

Constructors
Name Description
Public method EnergyAnalysisDetailModelOptions Constructs default options for energy analysis detailed model creation.
Top
Properties
Name Description
Public property EnergyModelType It indicates whether the energy model is based on rooms/spaces or building elements.
Public property ExportMullions Indicates if to specify the setting for exporting mullions.
Public property IncludeShadingSurfaces Indicates if to set and get the setting for if shading surfaces should be included.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SimplifyCurtainSystems Indicates if to specify the setting for simplified curtain systems.
Public property Tier Level of computation for energy analysis model.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the EnergyAnalysisDetailModelOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also