AssemblyTypeName Property


Assembly Instance Assembly Type Name Property

The name for the assembly type. All matching assembly instances share this name. Unique assembly instances are named automatically based on their naming category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string AssemblyTypeName { get; set; }

Property Value

String
Exceptions
Exception Condition
ArgumentException When setting this property: This assembly type name is not valid for this assembly instance. An assembly type name should be non-empty, should contain valid characters, and should be unique for its naming category.
ArgumentNullException When setting this property: A non-optional argument was null
See Also