UIMacroManager Class


UIMacro Manager Class

The UI macro manager to support Macro operations.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI.Macros UIMacroManager

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUIMacros (in RevitAPIUIMacros.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class UIMacroManager : IDisposable

The UIMacroManager type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MacroManager The DB macro manager.
Top
Methods
Name Description
Public method AddModule Adds a MacroModule to the application.
Public method Dispose Releases all resources used by the UIMacroManager
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Static member GetMacroManager Gets the UI Macro manager from the UI application.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method RemoveModule Removes a MacroModule.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also