IExternalApplication Interface


IExternal Application Interface

An interface that supports addition of external applications to Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IExternalApplication

The IExternalApplication type exposes the following members.

Methods
Name Description
Public method OnShutdown Implement this method to execute some tasks when Autodesk Revit shuts down.
Public method OnStartup Implement this method to execute some tasks when Autodesk Revit starts.
Top
Remarks
External applications are permitted to customize the Revit UI, and to add events and updaters to the session.
See Also