Element Get |
Gets the collection of ExternalResourceReference associated with a specified external resource type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public IList<ExternalResourceReference> GetExternalResourceReferenceExpanded(
ExternalResourceType resourceType
)
Parameters
- resourceType ExternalResourceType
- The desired external resource type.
Return Value
IList ExternalResourceReferenceThe collection of the ExternalResourceReference associated with a specified external resource type.

Exception | Condition |
---|---|
ArgumentException | This Element does not use a resource reference for the specified resource type. |
ArgumentNullException | A non-optional argument was null |

Use this API for an element which has multiple external resource references under a specified type, e.g., AppearanceAssetElement. See also: [!:Autodesk::Revit::DB::Element::getExternalResourceReference] .