Alignment Get |
Calculates the relative distance along the alignment between two stations based on their alignment distances according to Revit Internal Origin Coordinate Base. The distance may be positive or negative depending on the relative positions of the input stations on the alignment.
Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- fromStation Double
- The displayed alignment station from which 2D length is to be calculated, in Revit internal model units (standard Imperial feet).
- toStation Double
- The displayed alignment station to which 2D length is to be calculated, in Revit internal model units (standard Imperial feet).
Return Value
DoubleDistance (positive or negative) along the alignment between two stations. The sign of the distance depends on the relative positions of the input stations on the alignment.