Rebar |
Checks if the specified RebarHookType id is of a valid RebarHookType for the Rebar's RebarBarType
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- proposedHookId ElementId
- The Id of the RebarHookType
Return Value
BooleanReturns true if the id is of a valid RebarHookType for the Rebar element.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Also, checks that the Style of the Hook matches that of the Rebar's RebarShape