Line |
Creates a new hosted line load within the project.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static LineLoad Create(
Document document,
ElementId hostElemId,
XYZ forceVector1,
XYZ momentVector1,
LineLoadType symbol
)
Parameters
- document Document
- Document to which new line load will be added.
- hostElemId ElementId
- The analytical host element for the line Load.
- forceVector1 XYZ
- The applied 3d force vector.
- momentVector1 XYZ
- The applied 3d moment vector.
- symbol LineLoadType
- The symbol of the LineLoad. Set to use default type.
Return Value
LineLoadIf successful, returns the newly created LineLoad, otherwise.

Exception | Condition |
---|---|
ArgumentException | The element hostElemId does not exist in the document -or- hostElemId is not permitted for this type of load. |
ArgumentNullException | A non-optional argument was null |
ArgumentsInconsistentException | Thrown when all force and moment vectors are equal zero. |
InvalidOperationException | Thrown if type could not be set for newly created line load. |