RectangleLightShape Class


Rectangle Light Shape Class

This class encapsulates a rectangle light shape.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting LightShape
Autodesk.Revit.DB.Lighting RectangleLightShape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RectangleLightShape : LightShape

The RectangleLightShape type exposes the following members.

Constructors
Name Description
Public method RectangleLightShape Creates a rectangle light shape object with 4.0' emit length and a 2.0' emit width.
Public method RectangleLightShape(RectangleLightShape) Creates a copy of the given rectangle light shape
Public method RectangleLightShape(Double, Double) Creates a rectangle light shape object with the given emit length and width.
Top
Properties
Name Description
Public property EmitLength The emit length.
Public property EmitWidth The emit width.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from LightShape )
Top
Methods
Name Description
Public method Clone Creates a copy of the LightShape derived object.
(Inherited from LightShape )
Public method Dispose
(Inherited from LightShape )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also