Document |
The event arguments used by the DocumentOpening event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.DB.Events DocumentOpeningEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.DB.Events DocumentOpeningEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The DocumentOpeningEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | DocumentType | Type of the document, e.g. Project or Template. |
![]() | PathName | Path of the document to be opened. |

Name | Description | |
---|---|---|