FamilySizeTable Class


Family Size Table Class

Contains size information for a family.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FamilySizeTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilySizeTable : IDisposable

The FamilySizeTable type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property NumberOfColumns Number of columns in the table.
Public property NumberOfRows Number of rows in the table.
Top
Methods
Name Description
Public method AsValueString Gets the table cell value as a string.
Public method Dispose Releases all resources used by the FamilySizeTable
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetColumnHeader Gets a column of the table at at given index.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsValidColumnIndex Checks if the column index is valid.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also