Energy |
Checks that the building operating schedule falls within an appropriate range.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool CheckBuildingOperatingSchedule(
gbXMLBuildingOperatingSchedule buildingOperatingSchedule
)
Parameters
- buildingOperatingSchedule gbXMLBuildingOperatingSchedule
- The building operating schedule to be checked.
Return Value
BooleanTrue if the building operating schedule falls within an appropriate range, false otherwise.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |