Image |
Indicates whether the image type is a link or an import.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentException | When setting this property: The ImageType source is not correct. Only Link or Import values are allowed. |
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |

Use this property with the method ImageType::Create to create a linked image type. Use this property with the method ImageType::ReloadFrom to convert an import image type to a link and vice versa. Valid values are 'Import' and 'Link'.