ExternalResourceUtils Class


External Resource Utils Class

A utility class containing functions related to external resource references.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternalResourceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ExternalResourceUtils

The ExternalResourceUtils type exposes the following members.

Methods
Name Description
Public method Static member GetAllExternalResourceReferences(Document) Gets the ids of all elements which refer to external resources.
Public method Static member GetAllExternalResourceReferences(Document, ExternalResourceType) Gets the ids of all elements which refer to a specific type of external resource.
Top
Remarks
Elements which are external resource references refer to data outside of the base .rvt file. Examples include Revit links and the keynote table data.
See Also