InitialFileName Property


File Save Dialog Initial File Name Property

The initial file name to be shown for this save operation.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string InitialFileName { get; set; }

Property Value

String

This would typically be a name derived by the application that matches the purpose of the save operation it intends to do. The user is permitted to alter the initial file name.

If the extension is not included, the file would be given the selected file extension for the active filter (when saved). If the extension is included, it will be ignored if the extension does not match one of the possible filter extensions. When not set, the file name entry field in the dialog will be blank and the user will have to enter a file name.

Exceptions
Exception Condition
ArgumentException When setting this property: initialFileName cannot include prohibited unprintable characters.
ArgumentNullException When setting this property: A non-optional argument was null
See Also