EvaluatedParameter Class


Evaluated Parameter Class

Hold the evaluated ParameterValue and Definition of a parameter.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB EvaluatedParameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class EvaluatedParameter : IDisposable

The EvaluatedParameter type exposes the following members.

Properties
Name Description
Public property Definition Definition of the parameter.
Public property HasValue This property is true when the parameter value was successfully obtained, false otherwise.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property StorageType The storage type describes the type that is used internally within the parameter to store its value.
Public property Value Evaluated value of the parameter.
Top
Methods
Name Description
Public method AsValueString(Document) Get the parameter value as a string with units.
Public method AsValueString(Document, FormatOptions) Get the parameter value as a string with units.
Public method Dispose Releases all resources used by the EvaluatedParameter
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also