SetFailureHandlingOptions Method


Transaction Set Failure Handling Options Method

Sets options for handling failures to be used when the transaction is being committed or rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetFailureHandlingOptions(
	FailureHandlingOptions options
)

Parameters

options FailureHandlingOptions
An instance of FailureHandlingOptions to be applied to the transaction
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Options can be set at any time before the transaction is either committed or rolled back. See FailureHandlingOptions for details about available options. Once committed or rolled back, the transaction object will reset its options to their default values.
See Also