CreateRebarSpliceType Method


Rebar Splice Type Utils Create Rebar Splice Type Method

Creates a Rebar Splice Type element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementType CreateRebarSpliceType(
	Document document,
	string typeName
)

Parameters

document Document
The document.
typeName String
The Rebar Splice Type name.

Return Value

ElementType
The Rebar Splice Type.
Exceptions
Exception Condition
ArgumentException The given value for typeName cannot be an empty string. -or- The given value for typeName cannot include prohibited characters. -or- The given value for typeName is already in use by another Rebar Splice Type.
ArgumentNullException A non-optional argument was null
See Also